the latest account I created can't create cardsets

and it turned out an older account also forgot its cardset(s).

The issue is not reproducible and one of the accounts that had the issue before is fine now. The logs are fine or at least I guess this is unrelated:

2014-08-16_01:36:29 ERROR controllers.CardSets.updateCardSetRelations - Exception occurred while updating cardSetPriorities: 
java.lang.NullPointerException: null
  at controllers.CardSets.updateCardSetRelations(CardSets.java:224) ~[fluxcards.fluxcards-1.0-SNAPSHOT.jar:1.0-SNAPSHOT]
  at Routes$$anonfun$routes$1$$anonfun$applyOrElse$47$$anonfun$apply$47.apply(routes_routing.scala:653) ~[fluxcards.fluxcards-1.0-SNAPSHOT.jar:na]
  at Routes$$anonfun$routes$1$$anonfun$applyOrElse$47$$anonfun$apply$47.apply(routes_routing.scala:653) ~[fluxcards.fluxcards-1.0-SNAPSHOT.jar:na]
  at play.core.Router$HandlerInvoker$$anon$7$$anon$2.invocation(Router.scala:183) ~[com.typesafe.play.play_2.10-2.2.3.jar:2.2.3]
  at play.core.Router$Routes$$anon$1.invocation(Router.scala:377) ~[com.typesafe.play.play_2.10-2.2.3.jar:2.2.3]
  at play.core.j.JavaAction$$anon$1.call(JavaAction.scala:56) ~[com.typesafe.play.play_2.10-2.2.3.jar:2.2.3]
  at global.Global$2.call(Global.java:204) ~[fluxcards.fluxcards-1.0-SNAPSHOT.jar:1.0-SNAPSHOT]
  at play.mvc.Security$AuthenticatedAction.call(Security.java:45) ~[com.typesafe.play.play_2.10-2.2.3.jar:2.2.3]
  at play.core.j.JavaAction$$anon$3.apply(JavaAction.scala:91) ~[com.typesafe.play.play_2.10-2.2.3.jar:2.2.3]
  at play.core.j.JavaAction$$anon$3.apply(JavaAction.scala:90) ~[com.typesafe.play.play_2.10-2.2.3.jar:2.2.3]
  at play.core.j.FPromiseHelper$$anonfun$flatMap$1.apply(FPromiseHelper.scala:82) ~[com.typesafe.play.play_2.10-2.2.3.jar:2.2.3]
  at play.core.j.FPromiseHelper$$anonfun$flatMap$1.apply(FPromiseHelper.scala:82) ~[com.typesafe.play.play_2.10-2.2.3.jar:2.2.3]
  at scala.concurrent.Future$$anonfun$flatMap$1.apply(Future.scala:251) ~[org.scala-lang.scala-library-2.10.3.jar:na]
  at scala.concurrent.Future$$anonfun$flatMap$1.apply(Future.scala:249) ~[org.scala-lang.scala-library-2.10.3.jar:na]
  at scala.concurrent.impl.CallbackRunnable.run(Promise.scala:32) ~[org.scala-lang.scala-library-2.10.3.jar:na]
  at play.core.j.HttpExecutionContext$$anon$2.run(HttpExecutionContext.scala:37) ~[com.typesafe.play.play_2.10-2.2.3.jar:2.2.3]
  at akka.dispatch.TaskInvocation.run(AbstractDispatcher.scala:42) ~[com.typesafe.akka.akka-actor_2.10-2.2.0.jar:2.2.0]
  at akka.dispatch.ForkJoinExecutorConfigurator$AkkaForkJoinTask.exec(AbstractDispatcher.scala:386) ~[com.typesafe.akka.akka-actor_2.10-2.2.0.jar:2.2.0]
  at scala.concurrent.forkjoin.ForkJoinTask.doExec(ForkJoinTask.java:260) ~[org.scala-lang.scala-library-2.10.3.jar:na]
  at scala.concurrent.forkjoin.ForkJoinPool$WorkQueue.runTask(ForkJoinPool.java:1339) ~[org.scala-lang.scala-library-2.10.3.jar:na]
  at scala.concurrent.forkjoin.ForkJoinPool.runWorker(ForkJoinPool.java:1979) ~[org.scala-lang.scala-library-2.10.3.jar:na]
  at scala.concurrent.forkjoin.ForkJoinWorkerThread.run(ForkJoinWorkerThread.java:107) ~[org.scala-lang.scala-library-2.10.3.jar:na]

I rather suspect some silent crash on the client.

What happened?

  1. I created an account (id 53eeb3c4e4b0f6e82534343f)
  2. I created a cardset (id 53eeb514e4b0f6e825343480 I guess)
  3. I went to /preferences to change language and backLearning
  4. I went back to /home and noticed the cardset was gone and only the FAQ was there.
  5. I created another cardset and hit F5 but again only saw the FAQ.
  6. I shared a cardset from another account on another machine with that account but this was not visible neither.
  7. Later I logged in to the broken account from another machine and the card sets were there.

On the same machine where we had the issues, we had the issues with another account that worked just fine before, too. It's a windows machine.

Status

Issue is closed for Release alpha 0.

Comments

Post a comment



optional
optional